Admin Reports - Poor Performance

Occasional Contributor

Admin Reports - Poor Performance

(Didn't realize there was a specfic Admin help forum so posting this question here also)

 

Existing customer with roughly 2TB of files up on Box at this time. 

 

We have noticed this past month or so very poor performance running reports from the Admin, ex. User Statistics or User Logs. Reports that used to take 10~15mins are now taking multiple days to complete and be exported to Reports folder OR are not completing at all. Usual reports are over a 3 month to 12 month timeframe. Space usage has been gradual, slow rise over the past year so, i.e. this was not an issue when we had 1.5TB.

 

Anyone else seeing this issue?
Wondering if it is an issue with our Box instance or a global one impacting other Box users.

 

Thanks

7 REPLIES
Valued Contributor

Re: Admin Reports - Poor Performance

Box's reporting has been having problems with scale for quite a while now.  We're currently at about 200TB/25K current users in our instance, and the reporting has been an issue for a long while.  I have heard in various places that they're working on making it better, but I don't know anything more specific.  I'd suggest taking it up with support and/or your CSM.

Occasional Contributor

Re: Admin Reports - Poor Performance

They are reporting that they are unaware of any issues outside of ours at this time.... 

 

If you don't mind me asking how do you perform reviews of Box file & user usage?

 

Thanks

Valued Contributor

Re: Admin Reports - Poor Performance

I'm not sure exactly what you mean by "file and user usage", but I've written a small script using the Box Python API to generate a list of all of our users and how much space they're using.
Occasional Contributor

Re: Admin Reports - Poor Performance

I was referring to the Admin Reports > User Statistics and Usage Logs. Sounds like you are leveraging an API that they provide to query directly. If so are you seeing performance issues with the API? 

Box Certified Professional

Re: Admin Reports - Poor Performance

Started experiencing this issue yesterday. I run a weekly user activity report to track user adoption and the report was listed as "in progress" until this morning when I binned the folder and tried again. Normally this report takes 15-20 minutes to complete.

Tags (2)
Senior Member

Re: Admin Reports - Poor Performance

I am experiencing the same problem with the user statistic report.  Support team indicates that they are working on the issue but can not give me a time frame for resolution.  

Community Manager

Re: Admin Reports - Poor Performance

Hi @brianevans1002 and @TylerYates,

 

Thanks for your post. You're referring to the recent issue of exporting reports correct (1.29.18)?

 

We're aware of this issue internally and the engineering team is currently working through the back log of delayed reports. Check with your support agent if you have already submitted a ticket and they can provide more information on what the progress of the engineers.

 

Thanks for raising this issue!

Users online (375)