Showing results for 
Search instead for 
Do you mean 
Reply
New Member
Posts: 1

Error: The current Box Sync cannot be used because Box Sync requires a NTFS or HFS file system....

Hello, I need  Box Sync to support APFS in order to continue using Box Sync.

I perform Apple beta testing/public preview for work and heavily rely on box sync to keep my work files in sync between by workstations. 

 

Please release a version that supports High Sierra soon! 

Community Manager
Posts: 323

Re: Error: The current Box Sync cannot be used because Box Sync requires a NTFS or HFS file system..

Hi @JeffGrisso

Thank you for your post!

For MacOS/OS X, Box currently supports the two latest, released versions (see our Browser and OS Support article for details). So presently Sync does not support APFS.

 

The Box Community team shares selected conversations on the community back to other Box teams from time to time, including product feedback. However, if you'd like to provide direct feedback, I recommend that you submit a case to Box support.

 

Thanks for your help and time in the Community!

New Contributor
Posts: 3

Re: Error: The current Box Sync cannot be used because Box Sync requires a NTFS or HFS file system..

I only wanted to add an expression of interest in seeing Box Drive support for High Sierra sooner, versus later. 

Community Manager
Posts: 323

Re: Error: The current Box Sync cannot be used because Box Sync requires a NTFS or HFS file system..

Ah, understood Rus. Thanks for the feedback!

Occasional Visitor
Posts: 1

Re: Error: The current Box Sync cannot be used because Box Sync requires a NTFS or HFS file system..

Fully agree. I'd also argue that if Box releases a beta-level version (use at your own risk) before High Sierra comes out of beta they will have a more  solid product when it GAs. Once the first supported version comes out if they have issues that will reflect badly on Box.

New Contributor
Posts: 4

Re: Error: The current Box Sync cannot be used because Box Sync requires a NTFS or HFS file system..

[ Edited ]

I got the new Box Drive to work with macOS 10.13 (currently on beta 5). This is absolutely unsupported by Box I am sure. 

 

Install the latest osxfuse from https://osxfuse.github.io

Install the latest Box Drive (quit out after the errors)

Trash /Library/Filesystems/box.fuse

Duplicate osxfuse.fs (select to highlight the file , press command-D)

rename the osxfuse copy.fs to box.fs

 

Re-launch Box.app

Enjoy!

 

 

 

New Contributor
Posts: 4

Re: Error: The current Box Sync cannot be used because Box Sync requires a NTFS or HFS file system..

I forgot to mention, you will need to use Pacifist from http://charlessoft.com in order to override the install check for macOS version.

Regular Visitor
Posts: 1

Re: Error: The current Box Sync cannot be used because Box Sync requires a NTFS or HFS file system..

Great work, thanks for this tip.  Works just fine for me.

Moderator
Posts: 122

Re: Error: The current Box Sync cannot be used because Box Sync requires a NTFS or HFS file system..

Thanks @mpebley for that great post!

 

@usurper did this solve your question? If so, give 'em props and tell the community by clicking the Accept Solution button beneath @mpebley post!

 

Thanks for your time in the community and appreciate your help!

 

New Contributor
Posts: 4

Re: Error: The current Box Sync cannot be used because Box Sync requires a NTFS or HFS file system..

This actually does not address the Box Sync issue (which still will not work on an APFS volume, which imho is ridunkulous, since dropbox, onedrive, Google Drive all work fine).

 

This is a workaround to get Box Drive (Box.app) to work on macOS 10.13.x builds (the dev team should really look at using the latest osxfuse to get this straight).

 

Mike