Launched: Box Tools for Windows 3.5.2.382

Box Employee

We have launched a new Box Tools for Windows that includes updates for .Net Framework 4.5.2 & TLS 1.2! If organizations are on .Net framework 4.5.2 or higher, then we recommend use this build, otherwise all other customers should use this build.

Comments
Occasional Contributor

Hello... can someone help me understand why there are 2 separate versions? 

 

Will support for .NET less than 4.5.2 go away at some point?

Box Employee

We are releasing a new version of Box Tools targeting .Net framework 4.5.2 or higher in order to enable communication using cryptographic protocols greater than TLS 1.0 to improve security. However, we have some customers who cannot immediately upgrade their .Net frameworks for various reasons. Therefore, we are also supporting a Box Tools version that is compatible with .net framework 4.0. 

 

Yes, we would eventually stop supporting .net frameworks less than v4.5.2 at some point.

 

 

 

 

 

 

 

Occasional Contributor

Thank you for the information. Is there a timeline for when when less than 4.5.2 will be unsupported?

Box Employee

We do not have an exact timeline yet but will be announced soon. 

Users online (292)