2019年5月13日までにアプリがTLS 1.2に準拠していることを確認してください

Moderator

2019年5月13日までにアプリがTLS 1.2に準拠していることを確認してください

みなさんのアプリはTLS1.2対応していますか?

BoxへのTLS1.0通信は2019年5月13日にすべてブロックされます。

 

5月13日以降もTLS1.1はサポートされる予定ですが、より強固なセキュリティに対応するためTLS1.2の対応をつよく推奨しています。

 

TLS1.2対応のテストURLがあります。このリンクはTLS1.2未満で接続しようとしてもブロックされます。

https://api-test.box.com/2.0/

 

このURLはBox Upload APIのみの対応とはなりますが、このURLに対してTLS1.2接続のテストができます。

 

各種SDKを使ったテスト方法は以下になります:

C# SDK

BoxConfig config = new BoxConfig(/* config parameters */);
config.BoxApiUri = new System.Uri("https://api-test.box.com/2.0/");

Java SDK

BoxAPIConnection api = new BoxAPIConnection(/* connection parameters */);
api.setBaseURL("https://api-test.box.com/2.0/");

Node SDK

var BoxSDK = require('box-node-sdk');
var sdk = new BoxSDK({
    /* Other configuration parameters */
    apiRootURL: 'https://api-test.box.com'
});

 

document:https://developer.box.com/docs/tls-1

 

ご質問等ありましたらコメント欄でお知らせください